# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])/$1$2/gm;t' <<< "*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*"