use strict;
my $str = '*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*';
my $regex = qr/(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";