import re
regex = re.compile(r"(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])", flags=re.MULTILINE)
test_str = "*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)