using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])";
string substitution = @"$1$2";
string input = @"*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}