$re = '/(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])/m';
$str = '*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;