re = /(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])/m
str = '*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result