#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\G(?!^)|\[)([^\]\[*]*)\*(?=[^\]\[]*\])"
Local $sString = "*ab*]abc**[a*b*c]d*[ab**c***d*e*f*]e[*"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)