#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxu)^\b(?!_) # start with a word character excluding underscore" & @CRLF & _
"(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit" & @CRLF & _
"(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper" & @CRLF & _
"(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower" & @CRLF & _
"(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters" & @CRLF & _
".{8,15}$ # 8 to 15 characters until the end"
Local $sString = "@TestHey123!" & @CRLF & _
"TestHey@123!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")