import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\b(?!_) # start with a word character excluding underscore\n"
+ "(?=[^\\d\\n]*\\d) # look ahead for any non-digits followed by a digit\n"
+ "(?=[^A-Z\\n]*[A-Z]) # look ahead for an upper preceded by any non-upper\n"
+ "(?=[^a-z\\n]*[a-z]) # look ahead for an lower preceded by any non-lower\n"
+ "(?=.*[!\\{\\}\\[\\]@\\#$%^&*()<>_~+\\-]) # one special character preceded by any characters\n"
+ ".{8,15}$ # 8 to 15 characters until the end";
final String string = "@TestHey123!\n"
+ "TestHey@123!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}