use strict;
my $str = '@TestHey123!
TestHey@123!
';
my $regex = qr/^\b(?!_) # start with a word character excluding underscore
(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end/mxup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}