$re = '/^\b(?!_) # start with a word character excluding underscore
(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end/mxu';
$str = '@TestHey123!
TestHey@123!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);