const regex = /^\b(?!_) # start with a word character excluding underscore
(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b(?!_) # start with a word character excluding underscore
(?=[^\\d\\n]*\\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\\[\\]@\\#$%^&*()<>_~+\\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end', 'gmu')
const str = `@TestHey123!
TestHey@123!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}