re = /^\b(?!_) # start with a word character excluding underscore
(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end/mx
str = '@TestHey123!
TestHey@123!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end