using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\b(?!_) # start with a word character excluding underscore
(?=[^\d\n]*\d) # look ahead for any non-digits followed by a digit
(?=[^A-Z\n]*[A-Z]) # look ahead for an upper preceded by any non-upper
(?=[^a-z\n]*[a-z]) # look ahead for an lower preceded by any non-lower
(?=.*[!{}\[\]@\#$%^&*()<>_~+\-]) # one special character preceded by any characters
.{8,15}$ # 8 to 15 characters until the end";
string input = @"@TestHey123!
TestHey@123!
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}