using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ \(](\w{2})";
string input = @"(05C20 20F05)
(20F55 62Qxx)
(17B20 22E40 22F30 65Fxx)
(20-04 20H20)
(05C25)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}