import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\(](\\w{2})";
final String string = "(05C20 20F05)\n"
+ "(20F55 62Qxx)\n"
+ "(17B20 22E40 22F30 65Fxx)\n"
+ "(20-04 20H20)\n"
+ "(05C25)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}