$re = '/[ \(](\w{2})/m';
$str = '(05C20 20F05)
(20F55 62Qxx)
(17B20 22E40 22F30 65Fxx)
(20-04 20H20)
(05C25)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);