re = /[ \(](\w{2})/m
str = '(05C20 20F05)
(20F55 62Qxx)
(17B20 22E40 22F30 65Fxx)
(20-04 20H20)
(05C25)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end