import re
regex = re.compile(r"[ \(](\w{2})", flags=re.MULTILINE)
test_str = ("(05C20 20F05)\n"
"(20F55 62Qxx)\n"
"(17B20 22E40 22F30 65Fxx)\n"
"(20-04 20H20)\n"
"(05C25)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")