using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[[^\]]+\]\s+\[[^\]]+\]\s+\w+)\s+(\[[^\]]+\])\s+(ThreadId:\s+\d+)\s+(ThreadName:)\s+(.+?)\s+(Logged from:.+)\s+";
string substitution = @"\1, \2,\n\3,\n\4 \5,\n\6,";
string input = @"[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off
[CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName:
Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}