package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[^\]]+\]\s+\[[^\]]+\]\s+\w+)\s+(\[[^\]]+\])\s+(ThreadId:\s+\d+)\s+(ThreadName:)\s+(.+?)\s+(Logged from:.+)\s+`)
var str = `[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off
[CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName:
Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)
`
var substitution = "\1, \2,\n\3,\n\4 \5,\n\6,"
fmt.Println(re.ReplaceAllString(str, substitution))
}