re = /(\[[^\]]+\]\s+\[[^\]]+\]\s+\w+)\s+(\[[^\]]+\])\s+(ThreadId:\s+\d+)\s+(ThreadName:)\s+(.+?)\s+(Logged from:.+)\s+/
str = '[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off
[CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName:
Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)
'
subst = '\\1, \\2,\\n\\3,\\n\\4 \\5,\\n\\6,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result