import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[[^\\]]+\\]\\s+\\[[^\\]]+\\]\\s+\\w+)\\s+(\\[[^\\]]+\\])\\s+(ThreadId:\\s+\\d+)\\s+(ThreadName:)\\s+(.+?)\\s+(Logged from:.+)\\s+";
final String string = "[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off \n\n"
+ " [CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName: \n\n"
+ " Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)\n\n\n\n"
+ " ";
final String subst = "\\1, \\2,\\n\\3,\\n\\4 \\5,\\n\\6,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}