# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[[^\]]+\]\s+\[[^\]]+\]\s+\w+)\s+(\[[^\]]+\])\s+(ThreadId:\s+\d+)\s+(ThreadName:)\s+(.+?)\s+(Logged from:.+)\s+"
test_str = ("[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off \n\n"
" [CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName: \n\n"
" Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)\n\n\n\n"
" ")
subst = "\\1, \\2,\\n\\3,\\n\\4 \\5,\\n\\6,"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.