import Foundation
let pattern = #"(\[[^\]]+\]\s+\[[^\]]+\]\s+\w+)\s+(\[[^\]]+\])\s+(ThreadId:\s+\d+)\s+(ThreadName:)\s+(.+?)\s+(Logged from:.+)\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off
[CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName:
Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1, \2,\n\3,\n\4 \5,\n\6,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)