const regex = new RegExp('(\\[[^\\]]+\\]\\s+\\[[^\\]]+\\]\\s+\\w+)\\s+(\\[[^\\]]+\\])\\s+(ThreadId:\\s+\\d+)\\s+(ThreadName:)\\s+(.+?)\\s+(Logged from:.+)\\s+', 'g')
const str = `[01/30/2018 15:01:24] [Visma.Workflow.Server.exe] Off
[CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb::0] ThreadId: 12 ThreadName:
Initializing of ERP client complete. Logged from: CompanyDatabaseUpgrader.CheckAndUpgradeCompanyDb (0)
`;
const subst = `\1, \2,\n\3,\n\4 \5,\n\6,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);