# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\G)\d/ /gm;t' <<< "1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line"