use strict;
my $str = '1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line';
my $regex = qr/(^|\G)\d/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";