re = /(^|\G)\d/m
str = '1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result