$re = '/(^|\G)\d/m';
$str = '1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;