const regex = /(^|\G)\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\G)\\d', 'gm')
const str = `1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);