using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\G)\d";
string substitution = @" ";
string input = @"1 12 end line
10 3 end line
50 444 end line
100 54 end line
1000 5 end line";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}