#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*"
Local $sString = "setting $Low" & @CRLF & _
" prop $Config A_STRING_HERE "5, 10, 15, 20"" & @CRLF & _
"setting $Medium" & @CRLF & _
" prop $Config A_STRING_HERE "10, 20, 40, 80"" & @CRLF & _
"setting $High" & @CRLF & _
" prop $Config A_STRING_HERE "20, 40, 80, 160"" & @CRLF & _
"setting $VeryHigh" & @CRLF & _
" prop $Config A_STRING_HERE "40, 80, 160, 320""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")