use strict;
my $str = 'setting $Low
prop $Config A_STRING_HERE "5, 10, 15, 20"
setting $Medium
prop $Config A_STRING_HERE "10, 20, 40, 80"
setting $High
prop $Config A_STRING_HERE "20, 40, 80, 160"
setting $VeryHigh
prop $Config A_STRING_HERE "40, 80, 160, 320"';
my $regex = qr/(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}