re = /(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*/
str = 'setting $Low
prop $Config A_STRING_HERE "5, 10, 15, 20"
setting $Medium
prop $Config A_STRING_HERE "10, 20, 40, 80"
setting $High
prop $Config A_STRING_HERE "20, 40, 80, 160"
setting $VeryHigh
prop $Config A_STRING_HERE "40, 80, 160, 320"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end