using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*";
string input = @"setting $Low
prop $Config A_STRING_HERE ""5, 10, 15, 20""
setting $Medium
prop $Config A_STRING_HERE ""10, 20, 40, 80""
setting $High
prop $Config A_STRING_HERE ""20, 40, 80, 160""
setting $VeryHigh
prop $Config A_STRING_HERE ""40, 80, 160, 320""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}