import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=setting \\$High\\n\\s*?prop \\$Config )A_STRING_HERE.*";
final String string = "setting $Low\n"
+ " prop $Config A_STRING_HERE \"5, 10, 15, 20\"\n"
+ "setting $Medium\n"
+ " prop $Config A_STRING_HERE \"10, 20, 40, 80\"\n"
+ "setting $High\n"
+ " prop $Config A_STRING_HERE \"20, 40, 80, 160\"\n"
+ "setting $VeryHigh\n"
+ " prop $Config A_STRING_HERE \"40, 80, 160, 320\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}