const regex = /(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=setting \\$High\\n\\s*?prop \\$Config )A_STRING_HERE.*', 'g')
const str = `setting \$Low
prop \$Config A_STRING_HERE "5, 10, 15, 20"
setting \$Medium
prop \$Config A_STRING_HERE "10, 20, 40, 80"
setting \$High
prop \$Config A_STRING_HERE "20, 40, 80, 160"
setting \$VeryHigh
prop \$Config A_STRING_HERE "40, 80, 160, 320"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}