import re
regex = re.compile(r"(?<=setting \$High\n\s*?prop \$Config )A_STRING_HERE.*")
test_str = ("setting $Low\n"
" prop $Config A_STRING_HERE \"5, 10, 15, 20\"\n"
"setting $Medium\n"
" prop $Config A_STRING_HERE \"10, 20, 40, 80\"\n"
"setting $High\n"
" prop $Config A_STRING_HERE \"20, 40, 80, 160\"\n"
"setting $VeryHigh\n"
" prop $Config A_STRING_HERE \"40, 80, 160, 320\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")