#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$"
Local $sString = "''" & @CRLF & _
"" & @CRLF & _
"'asdasd'" & @CRLF & _
"" & @CRLF & _
""sdfsdfsdf{{234234324}}"" & @CRLF & _
"" & @CRLF & _
""<sdfsdfsdf>{{234234}}<-"" & @CRLF & _
"" & @CRLF & _
""sdfsdf{{234}}" & @CRLF & _
"sdfsdf{{234234}}" & @CRLF & _
"234234{{4}}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")