re = /(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$/
str = '\'\'
\'asdasd\'
"sdfsdfsdf{{234234324}}"
"<sdfsdfsdf>{{234234}}<-"
"sdfsdf{{234}}
sdfsdf{{234234}}
234234{{4}}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end