import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?:(?:.+)?(?:\\{\\{)(?<NUM>\\d+)(?:\\}\\})(?:.+)?)$";
final String string = "''\n\n"
+ "'asdasd'\n\n"
+ "\"sdfsdfsdf{{234234324}}\"\n\n"
+ "\"<sdfsdfsdf>{{234234}}<-\"\n\n"
+ "\"sdfsdf{{234}}\n"
+ "sdfsdf{{234234}}\n"
+ "234234{{4}}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}