package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$`)
var str = `''
'asdasd'
"sdfsdfsdf{{234234324}}"
"<sdfsdfsdf>{{234234}}<-"
"sdfsdf{{234}}
sdfsdf{{234234}}
234234{{4}}"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}