import Foundation
let pattern = #"(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
''
'asdasd'
"sdfsdfsdf{{234234324}}"
"<sdfsdfsdf>{{234234}}<-"
"sdfsdf{{234}}
sdfsdf{{234234}}
234234{{4}}"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)