using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$";
string input = @"''
'asdasd'
""sdfsdfsdf{{234234324}}""
""<sdfsdfsdf>{{234234}}<-""
""sdfsdf{{234}}
sdfsdf{{234234}}
234234{{4}}""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}