$re = '/(?m)^(?:(?:.+)?(?:{{)(?<NUM>\d+)(?:}})(?:.+)?)$/';
$str = '\'\'
\'asdasd\'
"sdfsdfsdf{{234234324}}"
"<sdfsdfsdf>{{234234}}<-"
"sdfsdf{{234}}
sdfsdf{{234234}}
234234{{4}}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);