# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)/$1\n$2--$3--rgb: #{$hexToRGB($3)};/gm;t' <<< " --color-primary: #0017a8;
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-tertiary: #00ffe0;
--color-green-dark: #257426;
"