#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)"
Local $sString = " --color-primary: #0017a8;" & @CRLF & _
" --variablename: blabla blablabla;" & @CRLF & _
" --color-secondary: #0631ff;" & @CRLF & _
" --color-tertiary: #00ffe0;" & @CRLF & _
" --color-green-dark: #257426;" & @CRLF & _
""
Local $sSubst = "$1\n$2--$3--rgb: #{$hexToRGB($3)};"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)