// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)").unwrap();
let string = " --color-primary: #0017a8;
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-tertiary: #00ffe0;
--color-green-dark: #257426;
";
let substitution = "$1\\n$2--$3--rgb: #{$hexToRGB($3)};";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}