$re = '/(( *?)--([A-z\-0-9]*?): (#[a-z0-9]*?);)/m';
$str = ' --color-primary: #0017a8;
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-tertiary: #00ffe0;
--color-green-dark: #257426;
';
$subst = "$1\n$2--$3--rgb: #{$hexToRGB($3)};";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;